<html lang="en-us">

<head>
<link href='https://fonts.googleapis.com/css?family=PT+Mono|Open+Sans:400,700|Inconsolata:400,700' rel='stylesheet' type='text/css' />
  <meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel="alternate" type="application/rss+xml" title="RSS" href="http://feedpress.me/sixcolors" />
<link rel="mask-icon" href="https://sixcolors.com/images/20156c.svg" color="black">
 <link rel="stylesheet" href="https://sixcolors.com/6c.css?date=20180929" type="text/css" />
<meta name="description" content="Six Colors by Jason Snell and Dan Moren" />
<link rel="shortcut icon" src="https://sixcolors.com/images/favicon.ico" /> 
<link rel="apple-touch-icon-precomposed" href="https://sixcolors.com/apple-touch-icon.png" />
<link rel="apple-touch-icon" sizes="60x60" href="https://sixcolors.com/apple-touch-icon-60.png" />
<link rel="apple-touch-icon" sizes="76x76" href="https://sixcolors.com/apple-touch-icon-76.png" />
<link rel="apple-touch-icon" sizes="120x120" href="https://sixcolors.com/apple-touch-icon-120.png" />
<link rel="apple-touch-icon" sizes="152x152" href="https://sixcolors.com/apple-touch-icon-152.png" />
<link rel="apple-touch-icon" sizes="180x180" href="https://sixcolors.com/apple-touch-icon-180.png" />

<script type="text/javascript">
  window.MemberfulOptions = {site: "https://sixcolors.memberful.com"};

  (function() {
    var s   = document.createElement('script');

    s.type  = 'text/javascript';
    s.async = true;
    s.src   = 'https://d35xxde4fgg0cx.cloudfront.net/assets/embedded.js';

    setup = function() { window.MemberfulEmbedded.setup(); }

    if(s.addEventListener) { s.addEventListener("load", setup, false); } else { s.attachEvent("onload", setup); }

    ( document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0] ).appendChild( s );
  })();
</script>


<meta name="keywords" content="Mac, iOS, OS X, Apple" />
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.3/jquery.min.js"></script>

<!--  jquery for mobile menu -->
 
<script type="text/javascript">
	jQuery(function($)
	{
	     $( '.menu-btn' ).click(function(){
	     $('.responsive-menu').toggleClass('expand')
	     })
    })
</script>
 


<link rel="search"
    type="application/opensearchdescription+xml"
    href="https://sixcolors.com/osd.xml"
    title="Six Colors" />

<title> Are we headed for a Mac automation schism? - Six Colors</title>

<link rel="stylesheet" href="/styles/bigfoot-default.css"/>
<script src="/js/jquery-2.1.1.min.js"></script>
<script src="/js/bigfoot.min.js"></script>
<script>
    $.bigfoot({
	numberResetSelector: "div.post"
});
</script>


<link rel="stylesheet" href="https://sixcolors.com/styles/carbon.css"/>




<meta name="entryid" content="9036" />
<meta name="author" content="Jason Snell" />
<meta property="og:title" content="Are we headed for a Mac automation schism?" />
<meta property="og:site_name" content="Six Colors" />
<meta property="og:url" content="https://sixcolors.com/post/2019/05/are-we-headed-for-a-mac-automation-schism/" />
<meta property="og:type" content="article" />


<meta property="og:image" content="https://sixcolors.com/images/content/2019/automator-shortcuts-6c.jpg" />


<meta property="og:description" content="
Steve Jobs introducing Automator in 2004 (left) and Craig Federighi introducing Shortcuts in 2018.


User automation is important. Giving users the power to eliminate repetitive tasks and connect apps together in ways the app designers never anticipated ..." />
 <meta property="article:author" content="https://www.facebook.com/jsnell" />

   <!-- Twitter Summary Card Data -->
    <!-- https://dev.twitter.com/docs/cards/types/summary-card -->
    <meta name="twitter:card" content="summary">
    <meta name="twitter:site" content="@bleedsixcolors">
    <meta name="twitter:creator" content="@jsnell">
    <meta name="twitter:url" content="https://sixcolors.com/post/2019/05/are-we-headed-for-a-mac-automation-schism/">
    <meta name="twitter:title" content="Are we headed for a Mac automation schism?">
    <meta name="twitter:description" content=" Steve Jobs introducing Automator in 2004 (left) and Craig Federighi introducing Shortcuts in 2018. User automation is important. Giving users the power to eliminate repetitive tasks and connect apps together in ways the app designers never anticipated helps harness...">

<meta name="twitter:image" content="https://sixcolors.com/images/content/2019/automator-shortcuts-6c.jpg" />


</head>

<body>



<header>
	
	    <div class="logo_sm">		
		    <a href="/"><img srcset="/images/6colorsheader_sm_2x.png 2x, /images/6colorsheader_sm_1x.png 1x" src="/images/6colorsheader_sm_1x.png" alt="six colors" /></a>
		</div>
		
		<div class="logo_lg">	
		    <a href="/"><img src="/images/6colors_lg_2x.png"/></a>
		</div>
		
		<p class="sitebyline">
		<span>by Jason Snell & Dan Moren</span> 
		</p>
	
	</header>
		
	<div class="mobile-nav">
	     <div class="menu-btn" id="menu-btn">
		     <div>MENU</div>
	     </div>
	 
	     <div class="responsive-menu">
	        <ul>
	           <li><a href="/about/">About</a>
	           </li>
	           <li><a href="/sponsor/">Advertise</a>
	           </li>
	           <li><a href="/archive/">Archive</a>
	           </li>
         <li><a href="/podcasts/">Podcasts</a>
	           </li>
	           <li><a href="/subscribe/">Support/Members</a>
	           </li>
	           <li>Topics
	           <a href="/topic/ios12/"><em>iOS 12</em></a>

	           <a href="/topic/mojave/"><em>macOS Mojave</em></a>

	           <a href="/topic/kindle/"><em>Kindle</em></a>

	           <a href="/topic/giftguide/"><em>Gift Guide</em></a>
	          
	           <a href="/topic/appletv/"><em>Apple TV</em></a>

	           <a href="/topic/applewatch/"><em>Apple Watch</em></a>
	           	           
	           <a href="/topic/podcasting/"><em>Podcasting</em></a>
	            
	           <a href="/topic/photosmac/"><em>Photos app</em></a>

	           <a href="/reviews/"><em>Reviews</em></a>

</li>
	        </ul>
	     </div><!-- responsive-menu -->
	     
	</div>  <!-- mobile-nav -->
		
	<div id="navbar">
	
		<ul>
		
			<li><a href="/about/">About</a></li>
			<li><a href="/sponsor/">Advertise</a></li>
			<li><a href="/archive/">Archive</a></li>
			<li><a href="/subscribe/">Membership</a></li>
	           <li><a href="/podcasts/">Podcasts</a></li>
			<li><a>Topics</a>
<ul>



	           <li><a href="/topic/ios12/"><em>iOS 12</em></a></li>

	           <li><a href="/topic/mojave/"><em>macOS Mojave</em></a></li>

	           <li><a href="/topic/kindle/"><em>Kindle</em></a></li>

	           <li><a href="/topic/giftguide/"><em>Gift Guide</em></a></li>
	          
	           <li><a href="/topic/appletv/"><em>Apple TV</em></a></li>

	           <li><a href="/topic/applewatch/"><em>Apple Watch</em></a></li>
	           	           
	           <li><a href="/topic/podcasting/"><em>Podcasting</em></a></li>
	            
	           <li><a href="/topic/photosmac/"><em>Photos app</em></a></li>

	           <li><a href="/reviews/"><em>Reviews</em></a></li>


</ul>

		</ul>
		
	</div><!-- navbar -->
	


<div class="main">


	<div class="topsponsor">
 <h4>Support this Site</h4> 
<!-- <h4>This week's sponsor</h4> -->    



<p>

<strong><a href="https://sixcolors.com/subscribe/">Become a Six Colors member</a></strong> and get access to an exclusive weekly podcast, community, newsletter and more.

</p>


		</div> 

 <!-- topsponsor -->








	<div class="post">





			<div class="article">

				<div class="column1">
					<h3>By Jason Snell</h3>
					<p class="dateline">May  1, 2019  3:21 PM PT</p>



		</div><!-- column1 -->
				
				<div class="column2">
					<h1>Are we headed for a Mac automation schism?</h1>

 <p><figure><img src="https://sixcolors.com/images/content/2019/automator-shortcuts-6c.jpg" alt="" />
<figcaption>Steve Jobs introducing Automator in 2004 (left) and Craig Federighi introducing Shortcuts in 2018.</figcaption>
</figure></p>

<p>User automation is important. Giving users the power to eliminate repetitive tasks and connect apps together in ways the app designers never anticipated helps harness the power of computers to make our lives easier. Even people who aren&#8217;t comfortable with building automation systems themselves can benefit from work created by others. User automation makes computing devices more powerful and their users more efficient.</p>

<p>The Mac is currently at the start of a pretty dramatic transition. This year, the platform will be flooded with apps that are based on the iOS app development system, UIKit, using a system that everyone calls Marzipan because Apple hasn&#8217;t given it a name. (My guess is that Apple won&#8217;t brand it at all, and will just call it &#8220;UIKit for macOS.&#8221;</p>

<p>Part of this transition affects user automation. macOS has a bunch of different system-level user automation technologies of various ages, but none of them work with iOS and Apple has shown no intention of changing that now. AppleEvents, AppleScript, and Automator already feel like legacy technologies that are maintained minimally to keep up compatibility, but they don&#8217;t feel like the future.</p>

<p>For years, iOS seemed to be a wasteland of user automation, but determined app developers discovered ways their apps could interact, most notably by embedding data in URLs&#8212;yep, the same strings of text you use to visit webpages&#8212;and passing them back and forth. Apple seemingly endorsed this technique when it bought Workflow, a popular third-party iOS automation app, and renamed it Shortcuts last summer. At the same time, Apple connected iOS automation to Siri through a feature called Siri Shortcuts, which fits right into existing systems already used by developers.</p>

<h2 id="automationschism">Automation schism</h2>

<p>So what happens when iOS apps comes to the Mac this fall? It seems impossible that Apple will allow them to be controlled by AppleScript and Automator. On iOS, they can be controlled by Shortcuts. Does that app make the move to macOS? According to 9to5Mac&#8217;s Guilherme Rambo, it might, and <a href="https://9to5mac.com/2019/04/19/siri-shortcuts-screen-time-mac/">Siri Shortcuts will</a>.</p>

<p>Will &#8220;classic&#8221; Mac apps&nbsp;<a href="#fn:classic" id="fnref:classic" title="see footnote" class="footnote">1</a> get the ability to be controlled via Shortcuts, too? Or will there be a schism between the two different classes of apps? (It&#8217;s not great for Mac users if there are two different kind of apps that live side by side and are supposed to be the same but are secretly &#8220;Type A&#8221; and &#8220;Type B&#8221; apps with different functionality. That happened a lot in the early days of Mac OS X and it was not great.) </p>

<p>And what about Automator and Shortcuts, two apps with similar approaches and aims? Do they live awkwardly side by side on macOS, each addressing some percentage of a user&#8217;s apps while ignoring the rest?</p>

<p>I&#8217;ve got to think Apple won&#8217;t leave the developers of &#8220;old-style&#8221; Mac apps high and dry. My hope is that Apple will provide developers of old-school Mac apps with some tools to integrate their apps with whatever automation system comes along with the new stuff, presumably Shortcuts. </p>

<p><figure><img src="https://sixcolors.com/images/content/2019/shortcuts-ssh-6c.jpg" alt="" />
<figcaption>&#8220;Run Script Over SSH&#8221; can be a gateway to the rest of macOS from the UIKit side.</figcaption>
</figure></p>

<p>If the goal is to avoid a complete schism, Apple could allow users to build their own bridges between apps by adding &#8220;Run shell script&#8221; and &#8220;Run AppleScript&#8221; commands within Shortcuts. While it might strike you as impossible that Apple would allow this, the truth is that the barn door is already open and the <a href="https://www.macstories.net/ipad-diaries/ipad-diaries-using-a-mac-from-ios-part-1-finder-folders-siri-shortcuts-and-app-windows-with-keyboard-maestro/">horse is long gone</a>. Shortcuts for iOS has an action that lets you run scripts on a remote server via SSH. If that feature ends up on the Mac, it&#8217;s over&#8212;all a user will have to do is tell the shortcut to connect to <code>localhost</code>.</p>

<p>What&#8217;s more, one of macOS&#8217;s shell commands is <code>osascript</code>, which&#8212;you guessed it&#8212;executes AppleScript scripts. Which means I can already run AppleScript and command-line commands on my Mac via my iPad. So why shouldn&#8217;t I be able to do so from my Mac? Doesn&#8217;t make sense.</p>

<h2 id="sirishortcutsgateway">Siri Shortcuts gateway?</h2>

<p>Then there&#8217;s Siri Shortcuts, which 9to5Mac says are almost certainly coming to macOS. Since this is a system based on iOS technology, it would seem like classic Mac apps and features might be entirely left out. It&#8217;s a break-up that doesn&#8217;t need to happen, so long as the proper bridges are built.</p>

<p>Something funny happened in macOS Mojave. Apple actually brushed off some very old Mac OS X technology, Services, and gave it <a href="https://sixcolors.com/post/2018/06/mojave-beta/">a rebrand as Quick Actions</a>. Quick Actions are commands you can find in Quick Look previews, the Finder&#8217;s new Gallery view, and on the Touch Bar. Some are pre-built by Apple, but users can add their own by saving Automator actions as Quick Actions.</p>

<p>I have no idea what prompted Apple to bubble up Automator actions into more places in the macOS interface with Mojave, but Quick Actions strikes me as a pretty good companion to Siri Shortcuts. Imagine a scenario where apps originating on iOS can support Siri Shortcuts via the same methods they use on iOS. Now imagine that Siri Shortcuts can <em>also</em> use Quick Actions as a source for potential commands. Quick Actions are contextual, those old-school Mac apps can bring their own Quick Actions to the party, and users can build their own Quick Actions to do whatever they want. It would be a simple way to bridge the gap between the two different app types that Mac users will be using together, at least for a while.</p>

<p>I don&#8217;t know if Apple&#8217;s planning to do this, but it&#8217;s hard not to imagine macOS 10.15 causing a pretty dramatic class division between apps, and that&#8217;s bad for the user experience. Some weirdness is inevitable when you&#8217;ve got different apps using different System Folders, APIs, and the rest. But the more bridges that exist&#8212;ones that let the different apps work together for the benefit of users&#8212;the better.</p>

<h2 id="itsjustthebeginning">It&#8217;s just the beginning</h2>

<p>I have a million questions about the future of user automation on Apple&#8217;s platforms, beyond just the scope of the changes in macOS 10.15. Are URL schemes <em>really</em> the future of inter-application communication, or is Apple working on a new system that&#8217;s a successor to AppleEvents that will offer a more robust pathway than a giant string of plain text? Is Shortcuts going to gain more low-level capabilities on both platforms? Will third-party automation utilities like Keyboard Maestro be able to control UIKit apps effectively?</p>

<p>In the end, I&#8217;m not as concerned with <em>how</em> user automation is preserved on macOS as I am concerned that it <em>is</em>  preserved. Shortcuts is a remarkably powerful app, and even URL schemes can be richer than you might think&#8212;though they&#8217;re definitely inelegant. The Mac can help push automation technology forward across all of Apple&#8217;s platforms, if Apple wants to go in that direction. But whatever happens, it&#8217;s clear that iOS and macOS are going to face the future of user automation together, not separately.</p>

<div class="footnotes">
<hr />
<ol>

<li id="fn:classic"><p>We are probably about to enter an era where all the Mac apps built using AppKit, the development system that&#8217;s &#8220;native&#8221; to macOS, are going to start being referred to as &#8220;classic&#8221; Mac apps, and the new UIKit apps are going to be called &#8220;new&#8221; Mac apps. <a href="#fnref:classic" title="return to article" class="reversefootnote">&#160;&#8617;</a></p></li>

</ol>
</div>




<a name="more"></a>




<p>[<em>If you appreciate articles like this one, help us continue doing Six Colors (and get some fun benefits) by <a href="https://sixcolors.com/subscribe/">becoming a Six Colors subscriber</a>.</em>]</p>








   				</div><!-- column2 -->
			</div><!-- article -->
		</div><!-- post -->




<hr class="separator">





		
</div> <!-- main -->

	
	<hr class="separator last">


<div class="footer">
		Copyright &copy; The Incomparable Inc.  &nbsp; 	           <a href="/sponsor/">Sponsorship Info</a> | <a href="https://sixcolors.com/subscribe/#feeds">Feeds</a> | <a href="http://twitter.com/bleedsixcolors">Twitter</a> | <a href="/search/">Search</a> | <a href="https://sixcolors.memberful.com/account">My Account</a> | <a href="https://www.theincomparable.com/blog/posts/privacy.html">Privacy Policy</a>
	</div><!-- footer -->
<script type='text/javascript'>var _merchantSettings=_merchantSettings || [];_merchantSettings.push(['AT', '10lMbH']);(function(){var autolink=document.createElement('script');autolink.type='text/javascript';autolink.async=true; autolink.src= ('https:' == document.location.protocol) ? 'https://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js' : 'http://autolinkmaker.itunes.apple.com/js/itunes_autolinkmaker.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(autolink, s);})();</script>

<!-- Local Stats -->
<script type="text/javascript">
  var _paq = _paq || [];
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//sixcolors.com/localstats/";
    _paq.push(['setTrackerUrl', u+'localstats.php']);
    _paq.push(['setSiteId', 1]);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'localstats.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//sixcolors.com/localstats/localstats.php?idsite=1" style="border:0;" alt="" /></p></noscript>
<!-- End Local Stats Code -->

<script type="text/javascript">
var loc = window.location.href; 
if (loc.includes('genius.it')) {
    offset = loc.indexOf('genius.it');
    newloc = loc.slice(0,offset)+ loc.slice(offset+'genius.it/'.length);
    window.location.replace(newloc);
    }
</script>


</body>
</html>